# CVE-2023-27490: Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth

> Attackers can bypass OAuth security checks to log in as victims by intercepting or manipulating authorization URLs in next-auth applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-7r7x-4c4q-c4qf

## What is CVE-2023-27490?

CVE-2023-27490 is a high-severity authentication bypass vulnerability in nextauthjs next-auth, published on 9 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NextAuth.js is an open source authentication solution for Next.js applications. `next-auth` applications using OAuth provider versions before `v4.20.1` have been found to be subject to an authentication vulnerability. A bad actor who can read traffic on the victim's network or who is able to social engineer the victim to click a manipulated login link could intercept and tamper with the authorization URL to **log in as the victim**, bypassing the CSRF protection. This is due to a partial failure during a compromised OAuth session where a session code is erroneously generated. This issue has been addressed in version 4.20.1. Users are advised to upgrade. Users unable to upgrade may using Advanced Initialization, manually check the callback request for state, pkce, and nonce against the provider configuration to prevent this issue. See the linked GHSA for details.

Weakness: CWE-384 (Session Fixation), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2023-27490?

2 open source packages ship an affected version, including next-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-auth` | npm | All versions | 4.20.1 |
| `next-auth` | npm | All versions | 4.20.1 |

Products: Nextauth.js Next-Auth.

## How do I fix CVE-2023-27490?

Upgrade next-auth to 4.20.1 or later.

## Is CVE-2023-27490 being exploited?

There is no known exploitation of CVE-2023-27490 in the wild and no public exploit code.

## Other vulnerabilities in nextauthjs next-auth

- [CVE-2022-35924](https://insights.sbomify.com/CVE-2022-35924/): Verification requests (magic link) sent to unwanted emails (critical 9.1)
- [CVE-2022-31093](https://insights.sbomify.com/CVE-2022-31093/): Improper Handling of `callbackUrl` parameter in next-auth (high 7.5)
- [CVE-2022-31127](https://insights.sbomify.com/CVE-2022-31127/): Improper handling of email input in next-auth (high 7.1)
- [CVE-2022-39263](https://insights.sbomify.com/CVE-2022-39263/): NextAuth.js Upstash Adapter missing token verification (medium 6.8)
- [CVE-2022-29214](https://insights.sbomify.com/CVE-2022-29214/): URL Redirection to Untrusted Site ('Open Redirect') in next-auth (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27490 and fix it if it is affected.

What it is: CVE-2023-27490 is a high-severity authentication bypass vulnerability in nextauthjs next-auth, published on 9 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27490 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-auth (npm): affected all versions; fixed in 4.20.1
- next-auth (npm): affected all versions; fixed in 4.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27490/ (Markdown: https://insights.sbomify.com/CVE-2023-27490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27490
- OSV: https://osv.dev/vulnerability/CVE-2023-27490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27490/
Summaries are generated and may contain mistakes; the official description above is the record.
