{"answers":{"affected":"1 open source package ship an affected version, including envoy. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27491 exists.","fix":"Upgrade envoy to a fixed version for your release line: 1.22.9, 1.23.6, 1.24.4 or 1.25.3.","what":"CVE-2023-27491 is a medium-severity vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-27491 and fix it if it is affected.\n\nWhat it is: CVE-2023-27491 is a medium-severity vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27491 exists.\n\nAffected packages and fixed versions:\n- envoy (Bitnami): affected all versions; fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27491/ (Markdown: https://insights.sbomify.com/CVE-2023-27491/index.md)","id":"CVE-2023-27491","markdown":"https://insights.sbomify.com/CVE-2023-27491/index.md","name":"CVE-2023-27491","record":{"aliases":["BIT-envoy-2023-27491","GHSA-5jmv-cw9p-f9rp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Envoy proxy","requires_auth":"none","summary":"Attackers can bypass security policies by sending malformed HTTP/1 requests that Envoy forwards to non-compliant downstream services.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"envoy","vendor":"envoyproxy"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Envoy forwards invalid Http2/Http3 downstream headers","id":"CVE-2023-27491","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"envoyproxy:envoy","products":["envoyproxy:envoy"],"type":"security_feature_bypass","year":"2023"},"n_packages":1,"n_references":4,"next":{"headline":"Envoy may crash when a large request body is processed in Lua filter","id":"CVE-2023-27492"},"packages":[{"ecosystem":"Bitnami","fixed":["1.22.9","1.23.6","1.24.4","1.25.3"],"introduced":["0","1.23.0","1.24.0","1.25.0"],"last_affected":[],"package":"envoy","purl":"pkg:bitnami/envoy","source":"BIT-envoy-2023-27491"}],"prev":{"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490"},"products":["envoy"],"published":"2023-04-04","related":[{"cvss_score":10,"headline":"Trivial authentication bypass in Envoy","id":"CVE-2022-29226","kev_date_added":null,"published":"2022-06-09"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-18801","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2019-18802","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2020-35470","kev_date_added":null,"published":"2020-12-15"},{"cvss_score":8.6,"headline":"Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata","id":"CVE-2024-23324","kev_date_added":null,"published":"2024-02-09"},{"cvss_score":8.6,"headline":"Envoy vulnerable to OAuth2 credentials exploit with permanent validity","id":"CVE-2023-35941","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":8.6,"headline":"Incorrect handling of H2 GOAWAY + SETTINGS frames","id":"CVE-2021-39162","kev_date_added":null,"published":"2021-09-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-11","vendors":["envoyproxy"]},"summary":"Attackers can bypass security policies by sending malformed HTTP/1 requests that Envoy forwards to non-compliant downstream services.","url":"https://insights.sbomify.com/CVE-2023-27491/"}