# CVE-2023-27491: Envoy forwards invalid Http2/Http3 downstream headers

> Attackers can bypass security policies by sending malformed HTTP/1 requests that Envoy forwards to non-compliant downstream services.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** BIT-envoy-2023-27491, GHSA-5jmv-cw9p-f9rp

## What is CVE-2023-27491?

CVE-2023-27491 is a medium-severity vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-27491?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.22.9, 1.23.6, 1.24.4, 1.25.3 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2023-27491?

Upgrade envoy to a fixed version for your release line: 1.22.9, 1.23.6, 1.24.4 or 1.25.3.

## Is CVE-2023-27491 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27491 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27491 and fix it if it is affected.

What it is: CVE-2023-27491 is a medium-severity vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27491 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27491/ (Markdown: https://insights.sbomify.com/CVE-2023-27491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27491
- OSV: https://osv.dev/vulnerability/CVE-2023-27491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27491/
Summaries are generated and may contain mistakes; the official description above is the record.
