{"answers":{"affected":"1 open source package ship an affected version, including envoy. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27492 exists.","fix":"Upgrade envoy to a fixed version for your release line: 1.22.9, 1.23.6, 1.24.4 or 1.25.3.","what":"CVE-2023-27492 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-27492 and fix it if it is affected.\n\nWhat it is: CVE-2023-27492 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27492 exists.\n\nAffected packages and fixed versions:\n- envoy (Bitnami): affected all versions; fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27492/ (Markdown: https://insights.sbomify.com/CVE-2023-27492/index.md)","id":"CVE-2023-27492","markdown":"https://insights.sbomify.com/CVE-2023-27492/index.md","name":"CVE-2023-27492","record":{"aliases":["BIT-envoy-2023-27492","GHSA-wpc2-2jp6-ppg2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Envoy proxy","requires_auth":"low_privilege","summary":"Attackers can crash Envoy proxy by sending large request bodies to routes with the Lua filter enabled, requiring an upgrade to fix.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"envoy","vendor":"envoyproxy"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, the Lua filter is vulnerable to denial of service. Attackers can send large request bodies for routes that have Lua filter enabled and trigger crashes.\n\nAs of versions versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, Envoy no longer invokes the Lua coroutine if the filter has been reset. As a workaround for those whose Lua filter is buffering all requests/ responses, mitigate by using the buffer filter to avoid triggering the local reply in the Lua filter.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Envoy may crash when a large request body is processed in Lua filter","id":"CVE-2023-27492","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"envoyproxy:envoy","products":["envoyproxy:envoy"],"type":"denial_of_service","year":"2023"},"n_packages":1,"n_references":1,"next":{"headline":"Envoy doesn't escape HTTP header values","id":"CVE-2023-27493"},"packages":[{"ecosystem":"Bitnami","fixed":["1.22.9","1.23.6","1.24.4","1.25.3"],"introduced":["0","1.23.0","1.24.0","1.25.0"],"last_affected":[],"package":"envoy","purl":"pkg:bitnami/envoy","source":"BIT-envoy-2023-27492"}],"prev":{"headline":"Envoy forwards invalid Http2/Http3 downstream headers","id":"CVE-2023-27491"},"products":["envoy"],"published":"2023-04-04","related":[{"cvss_score":10,"headline":"Trivial authentication bypass in Envoy","id":"CVE-2022-29226","kev_date_added":null,"published":"2022-06-09"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-18801","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2019-18802","kev_date_added":null,"published":"2019-12-13"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2020-35470","kev_date_added":null,"published":"2020-12-15"},{"cvss_score":8.6,"headline":"Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata","id":"CVE-2024-23324","kev_date_added":null,"published":"2024-02-09"},{"cvss_score":8.6,"headline":"Envoy vulnerable to OAuth2 credentials exploit with permanent validity","id":"CVE-2023-35941","kev_date_added":null,"published":"2023-07-25"},{"cvss_score":8.6,"headline":"Incorrect handling of H2 GOAWAY + SETTINGS frames","id":"CVE-2021-39162","kev_date_added":null,"published":"2021-09-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-11","vendors":["envoyproxy"]},"summary":"Attackers can crash Envoy proxy by sending large request bodies to routes with the Lua filter enabled, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2023-27492/"}