# CVE-2023-27492: Envoy may crash when a large request body is processed in Lua filter

> Attackers can crash Envoy proxy by sending large request bodies to routes with the Lua filter enabled, requiring an upgrade to fix.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** BIT-envoy-2023-27492, GHSA-wpc2-2jp6-ppg2

## What is CVE-2023-27492?

CVE-2023-27492 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, the Lua filter is vulnerable to denial of service. Attackers can send large request bodies for routes that have Lua filter enabled and trigger crashes.

As of versions versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, Envoy no longer invokes the Lua coroutine if the filter has been reset. As a workaround for those whose Lua filter is buffering all requests/ responses, mitigate by using the buffer filter to avoid triggering the local reply in the Lua filter.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2023-27492?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.22.9, 1.23.6, 1.24.4, 1.25.3 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2023-27492?

Upgrade envoy to a fixed version for your release line: 1.22.9, 1.23.6, 1.24.4 or 1.25.3.

## Is CVE-2023-27492 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27492 exists.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27492 and fix it if it is affected.

What it is: CVE-2023-27492 is a medium-severity denial of service vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27492 exists.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.22.9, 1.23.6, 1.24.4, 1.25.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27492/ (Markdown: https://insights.sbomify.com/CVE-2023-27492/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27492
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27492
- OSV: https://osv.dev/vulnerability/CVE-2023-27492

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27492/
Summaries are generated and may contain mistakes; the official description above is the record.
