CVE-2023-27493 Envoy doesn't escape HTTP header values
Attackers can inject illegal characters into HTTP headers, potentially causing request smuggling and bypassing security policies in Envoy proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-27493?
CVE-2023-27493 is a high-severity vulnerability in Envoyproxy Envoy, published on 4 Apr 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, Envoy does not sanitize or escape request properties when generating request headers. This can lead to characters that are illegal in header values to be sent to the upstream service. In the worst case, it can cause upstream service to interpret the original request as two pipelined requests, possibly bypassing the intent of Envoy’s security policy. Versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9 contain a patch. As a workaround, disable adding request headers based on the downstream request properties, such as downstream certificate properties.
Which versions are affected by CVE-2023-27493?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.22.9, 1.23.6, 1.24.4, 1.25.3 |
Products include Envoyproxy Envoy.
How do I fix CVE-2023-27493?
Upgrade envoy to a fixed version for your release line: 1.22.9, 1.23.6, 1.24.4 or 1.25.3.
Is CVE-2023-27493 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27493 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2023-27493, GHSA-w5w5-487h-qv8q.