# CVE-2023-27506: Authenticated Local Privilege Escalation vulnerability in Intel Optimization for Tensorflow

> An authenticated local attacker can escalate privileges due to improper buffer restrictions in the Intel Optimization for TensorFlow library.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** GHSA-m2f8-v8q4-3m59, PYSEC-2026-1465, PYSEC-2026-2523, PYSEC-2026-3385

## What is CVE-2023-27506?

CVE-2023-27506 is a medium-severity vulnerability in Intel(R) Optimization for Tensorflow software, published on 11 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Improper buffer restrictions in the Intel(R) Optimization for Tensorflow software before version 2.12 may allow an authenticated user to potentially enable escalation of privilege via local access.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer), CWE-92 (DEPRECATED: Improper Sanitization of Custom Special Characters)

## Which versions are affected by CVE-2023-27506?

9 open source packages ship an affected version, including intel-tensorflow, intel-tensorflow-avx512 and tensorflow-intel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `intel-tensorflow` | PyPI | All versions | 2.12 |
| `intel-tensorflow` | PyPI | All versions | 2.12 |
| `intel-tensorflow` | PyPI | All versions | 2.12 |
| `intel-tensorflow-avx512` | PyPI | All versions | 2.12 |
| `intel-tensorflow-avx512` | PyPI | All versions | 2.12 |
| `intel-tensorflow-avx512` | PyPI | All versions | 2.12 |
| `tensorflow-intel` | PyPI | All versions | 2.12 |
| `tensorflow-intel` | PyPI | All versions | 2.12 |
| `tensorflow-intel` | PyPI | All versions | 2.12 |

Products: Intel Optimization for Tensorflow.

## How do I fix CVE-2023-27506?

Upgrade intel-tensorflow to 2.12 or later.

## Is CVE-2023-27506 being exploited?

There is no known exploitation of CVE-2023-27506 in the wild and no public exploit code.

## Other vulnerabilities in Intel(R) Optimization for Tensorflow software

- [CVE-2023-30767](https://insights.sbomify.com/CVE-2023-30767/): Memory corruption in TensorFlow (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27506 and fix it if it is affected.

What it is: CVE-2023-27506 is a medium-severity vulnerability in Intel(R) Optimization for Tensorflow software, published on 11 Aug 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27506 in the wild and no public exploit code.

Affected packages and fixed versions:
- intel-tensorflow (PyPI): affected all versions; fixed in 2.12
- intel-tensorflow (PyPI): affected all versions; fixed in 2.12
- intel-tensorflow (PyPI): affected all versions; fixed in 2.12
- intel-tensorflow-avx512 (PyPI): affected all versions; fixed in 2.12
- intel-tensorflow-avx512 (PyPI): affected all versions; fixed in 2.12
- intel-tensorflow-avx512 (PyPI): affected all versions; fixed in 2.12
- tensorflow-intel (PyPI): affected all versions; fixed in 2.12
- tensorflow-intel (PyPI): affected all versions; fixed in 2.12
- tensorflow-intel (PyPI): affected all versions; fixed in 2.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27506/ (Markdown: https://insights.sbomify.com/CVE-2023-27506/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27506
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27506
- OSV: https://osv.dev/vulnerability/CVE-2023-27506

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27506/
Summaries are generated and may contain mistakes; the official description above is the record.
