# CVE-2023-27524: Apache Superset Insecure Default Initialization of Resource

> Attackers can authenticate and access unauthorized resources if the default SECRET_KEY is not changed, requiring administrators to set a unique key.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Yes, since 8 Jan 2024 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2023
- **Updated:** 21 Oct 2025
- **Also known as:** BIT-superset-2023-27524, GHSA-5cx2-vq3h-x52c, PYSEC-2026-1161

## What is CVE-2023-27524?

CVE-2023-27524 is a high-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Session Validation attacks in Apache Superset versions up to and including 2.0.1. Installations that have not altered the default configured SECRET_KEY according to installation instructions allow for an attacker to authenticate and access unauthorized resources. This does not affect Superset administrators who have changed the default value for SECRET_KEY config.

All superset installations should always set a unique secure random SECRET_KEY. Your SECRET_KEY is used to securely sign all session cookies and encrypting sensitive information on the database.
Add a strong SECRET_KEY to your `superset_config.py` file like:

SECRET_KEY = <YOUR_OWN_RANDOM_GENERATED_SECRET_KEY>

Alternatively you can set it with `SUPERSET_SECRET_KEY` environment variable.

Weakness: CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2023-27524?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 2.1.0 |
| `apache-superset` | PyPI | All versions | 2.1.0 |
| `apache-superset` | PyPI | All versions | 2.1.0 |
| `superset` | Bitnami | All versions | 2.0.2 |

Products: Apache Superset.

## How do I fix CVE-2023-27524?

Upgrade apache-superset to 2.1.0 or later. US federal agencies must fix it by 29 Jan 2024.

## Is CVE-2023-27524 being exploited?

Yes. Attackers have exploited CVE-2023-27524 in the wild since at least 8 Jan 2024.

Public exploit code:

- Basic PoC for CVE-2023-27524: Insecure Default Configuration in Apache Superset (github_poc): https://github.com/horizon3ai/CVE-2023-27524
- https://github.com/jakabakos/CVE-2023-27524-Apache-Superset-Auth-Bypass-and-RCE (github_poc): https://github.com/jakabakos/CVE-2023-27524-Apache-Superset-Auth-Bypass-and-RCE
- Apahce-Superset身份认证绕过漏洞(CVE-2023-27524)检测工具 (github_poc): https://github.com/Okaytc/Superset_auth_bypass_check
- Apache Superset Auth Bypass (CVE-2023-27524) (github_poc): https://github.com/tardc/CVE-2023-27524
- Apache Superset Auth Bypass Vulnerability CVE-2023-27524. (github_poc): https://github.com/ZZ-SOCMAP/CVE-2023-27524
- Perform With Apache-SuperSet Leaked Token [CSRF] (github_poc): https://github.com/Ap0dexMe0/CVE-2023-27524

## Other vulnerabilities in Apache Superset

- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)
- [CVE-2021-41971](https://insights.sbomify.com/CVE-2021-41971/): Possible SQL Injection when template processing is enabled (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27524 and fix it if it is affected.

What it is: CVE-2023-27524 is a high-severity vulnerability in Apache Superset, published on 24 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2023-27524 in the wild since at least 8 Jan 2024.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 2.1.0
- apache-superset (PyPI): affected all versions; fixed in 2.1.0
- apache-superset (PyPI): affected all versions; fixed in 2.1.0
- superset (Bitnami): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27524/ (Markdown: https://insights.sbomify.com/CVE-2023-27524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27524
- OSV: https://osv.dev/vulnerability/CVE-2023-27524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27524/
Summaries are generated and may contain mistakes; the official description above is the record.
