CVE-2023-27525 Apache Superset: Incorrect default permissions for Gamma role

Low 3.1 Published Updated

Authenticated Gamma users can access unauthorized metadata information in Apache Superset due to incorrect default permissions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-27525?

CVE-2023-27525 is a low-severity missing authorization vulnerability in Apache Superset, published on 17 Apr 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An authenticated user with Gamma role authorization could have access to metadata information using non trivial methods in Apache Superset up to and including 2.0.1

Weakness: CWE-863

Which versions are affected by CVE-2023-27525?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.

PackageAffectedFixed in
apache-superset PyPIAll versions to 2.0.1None
apache-superset PyPIAll versions to 2.0.1None
apache-superset PyPIAll versions2.1.0
superset BitnamiAll versions2.0.2

Products include Apache Superset.

How do I fix CVE-2023-27525?

Upgrade apache-superset to 2.1.0 or later.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2023-27525 being exploited?

There is no known exploitation of CVE-2023-27525 in the wild and no public exploit code.

All Apache Superset vulnerabilities

Sources

Also known as BIT-superset-2023-27525, GHSA-7jhg-8m74-6f6g, PYSEC-2026-1163.

Is CVE-2023-27525 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free