# CVE-2023-27531: Kredis JSON Possible Deserialization of Untrusted Data Vulnerability

> Attackers can execute arbitrary code via deserialization of untrusted data in the Kredis JSON library for Ruby on Rails.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2025
- **Updated:** 9 Jan 2025
- **Also known as:** GHSA-h2wm-p2vg-6pw4

## What is CVE-2023-27531?

CVE-2023-27531 is a medium-severity unsafe deserialization vulnerability in Rails Kredis JSON, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There is a deserialization of untrusted data vulnerability in the Kredis JSON deserialization code

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-27531?

2 open source packages ship an affected version, including kredis.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kredis` | RubyGems | All versions | 1.3.0.1 |
| `kredis` | RubyGems | All versions | 1.3.0.1 |

## How do I fix CVE-2023-27531?

Upgrade kredis to 1.3.0.1 or later.

## Is CVE-2023-27531 being exploited?

There is no known exploitation of CVE-2023-27531 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27531 and fix it if it is affected.

What it is: CVE-2023-27531 is a medium-severity unsafe deserialization vulnerability in Rails Kredis JSON, published on 9 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27531 in the wild and no public exploit code.

Affected packages and fixed versions:
- kredis (RubyGems): affected all versions; fixed in 1.3.0.1
- kredis (RubyGems): affected all versions; fixed in 1.3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27531/ (Markdown: https://insights.sbomify.com/CVE-2023-27531/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27531
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27531
- OSV: https://osv.dev/vulnerability/CVE-2023-27531

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27531/
Summaries are generated and may contain mistakes; the official description above is the record.
