# CVE-2023-27561: Opencontainers runc Incorrect Authorization vulnerability

> An attacker with container spawn privileges can escalate privileges via incorrect access control in runc's rootfs handling.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2023
- **Updated:** 16 Dec 2025
- **Also known as:** AZL-25574, CLEANSTART-2026-IS70911, DEBIAN-CVE-2023-27561, GHSA-vpvm-3wq2-2wvm, GO-2023-1627, UBUNTU-CVE-2023-27561, openSUSE-SU-2024:12992-1

## What is CVE-2023-27561?

CVE-2023-27561 is a high-severity vulnerability in Debian Debian Linux, published on 3 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

runc through 1.1.4 has Incorrect Access Control leading to Escalation of Privileges, related to libcontainer/rootfs_linux.go. To exploit this, an attacker must be able to spawn two containers with custom volume-mount configurations, and be able to run custom images. NOTE: this issue exists because of a CVE-2019-19921 regression.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference)

## Which versions are affected by CVE-2023-27561?

3 open source packages ship an affected version, including github.com/opencontainers/runc. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/opencontainers/runc` | Go | From 1.0.0-rc95 | 1.1.5 |
| `github.com/opencontainers/runc` | Go | From 1.0.0-rc95 | 1.1.5 |
| `github.com/opencontainers/runc` | Go | From 1.0.0-rc95 | 1.1.5 |
| `kubernetes1.27` | openSUSE:Tumbleweed | All versions | 1.27.2-1.1 |

Products: Debian Debian Linux, Linuxfoundation Runc, Redhat Enterprise Linux, Redhat Openshift Container Platform.

## How do I fix CVE-2023-27561?

Upgrade github.com/opencontainers/runc to 1.1.5 or later.

## Is CVE-2023-27561 being exploited?

There is no known exploitation of CVE-2023-27561 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27561 and fix it if it is affected.

What it is: CVE-2023-27561 is a high-severity vulnerability in Debian Debian Linux, published on 3 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27561 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/opencontainers/runc (Go): affected from 1.0.0-rc95; fixed in 1.1.5
- github.com/opencontainers/runc (Go): affected from 1.0.0-rc95; fixed in 1.1.5
- github.com/opencontainers/runc (Go): affected from 1.0.0-rc95; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27561/ (Markdown: https://insights.sbomify.com/CVE-2023-27561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27561
- OSV: https://osv.dev/vulnerability/CVE-2023-27561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27561/
Summaries are generated and may contain mistakes; the official description above is the record.
