# CVE-2023-27562: n8n Directory Traversal vulnerability

> An attacker can exploit a directory traversal vulnerability in the n8n Node.js package to read arbitrary files from the server.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2023
- **Updated:** 27 Jan 2025
- **Also known as:** GHSA-p58x-7733-vp9m

## What is CVE-2023-27562?

CVE-2023-27562 is a medium-severity path traversal vulnerability in N8n N8n, published on 10 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The n8n package 0.218.0 for Node.js allows Directory Traversal.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-27562?

2 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 0.216.1 |
| `n8n` | npm | All versions | 0.216.1 |

Products: N8n N8n.

## How do I fix CVE-2023-27562?

Upgrade n8n to 0.216.1 or later.

## Is CVE-2023-27562 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27562 exists.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27562 and fix it if it is affected.

What it is: CVE-2023-27562 is a medium-severity path traversal vulnerability in N8n N8n, published on 10 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27562 exists.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 0.216.1
- n8n (npm): affected all versions; fixed in 0.216.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27562/ (Markdown: https://insights.sbomify.com/CVE-2023-27562/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27562
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27562
- OSV: https://osv.dev/vulnerability/CVE-2023-27562

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27562/
Summaries are generated and may contain mistakes; the official description above is the record.
