CVE-2023-27563 n8n Privilege Escalation vulnerability
High 8.8
Published
Updated
Check this codebase for CVE-2023-27563 and fix it if it is affected.
What it is: CVE-2023-27563 is a high-severity vulnerability in N8n N8n, published on 10 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27563 exists.
Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 0.216.1
- n8n (npm): affected all versions; fixed in 0.216.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2023-27563/ (Markdown: https://insights.sbomify.com/CVE-2023-27563/index.md)
Attackers can escalate privileges within the n8n Node.js package, potentially gaining unauthorized control over the application.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-27563?
CVE-2023-27563 is a high-severity vulnerability in N8n N8n, published on 10 May 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The n8n package 0.218.0 for Node.js allows Escalation of Privileges.
Which versions are affected by CVE-2023-27563?
2 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 0.216.1 |
n8n npm | All versions | 0.216.1 |
Products include N8n N8n.
How do I fix CVE-2023-27563?
Upgrade n8n to 0.216.1 or later.
Is CVE-2023-27563 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27563 exists.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-97cp-mr4m-9mcf.