{"answers":{"affected":"2 open source packages ship an affected version, including flarum/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27577 in the wild and no public exploit code.","fix":"Upgrade flarum/core to 1.7.0 or later.","what":"CVE-2023-27577 is a medium-severity vulnerability in flarum framework, published on 10 Mar 2023."},"fix_prompt":"Check this codebase for CVE-2023-27577 and fix it if it is affected.\n\nWhat it is: CVE-2023-27577 is a medium-severity vulnerability in flarum framework, published on 10 Mar 2023. \nExploitation: There is no known exploitation of CVE-2023-27577 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flarum/core (Packagist): affected all versions; fixed in 1.7.0\n- flarum/core (Packagist): affected all versions; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27577/ (Markdown: https://insights.sbomify.com/CVE-2023-27577/index.md)","id":"CVE-2023-27577","markdown":"https://insights.sbomify.com/CVE-2023-27577/index.md","name":"CVE-2023-27577","record":{"aliases":["GHSA-vhm8-wwrf-3gcw"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files in flarum","id":"CVE-2023-27577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"Galaxy vulnerable to unauthorized modification of pages/visualizations due to insufficient permission check","id":"CVE-2023-27578"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-vhm8-wwrf-3gcw"},{"ecosystem":"Packagist","fixed":["1.7.0"],"introduced":["0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-vhm8-wwrf-3gcw"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2023-27576"},"products":["framework"],"published":"2023-03-10","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":9,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","kev_date_added":null,"published":"2022-11-19"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["flarum"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2023-27577/"}