# CVE-2023-27577: Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files in flarum


- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-vhm8-wwrf-3gcw

## What is CVE-2023-27577?

CVE-2023-27577 is a medium-severity vulnerability in flarum framework, published on 10 Mar 2023. 

### Official description

flarum is a forum software package for building communities. In versions prior to 1.7.0 an admin account which has already been compromised by an attacker may use a vulnerability in the `LESS` parser which can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file on a linux machine. The scope of what files are vulnerable will depend on the permissions given to the running flarum process. The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Users unable to upgrade may mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and follow other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls at the operating system level.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-27577?

2 open source packages ship an affected version, including flarum/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flarum/core` | Packagist | All versions | 1.7.0 |
| `flarum/core` | Packagist | All versions | 1.7.0 |

Products: Flarum Flarum.

## How do I fix CVE-2023-27577?

Upgrade flarum/core to 1.7.0 or later.

## Is CVE-2023-27577 being exploited?

There is no known exploitation of CVE-2023-27577 in the wild and no public exploit code.

## Other vulnerabilities in flarum framework

- [CVE-2021-32671](https://insights.sbomify.com/CVE-2021-32671/): XSS vulnerability with translator (critical 10.0)
- [CVE-2022-41938](https://insights.sbomify.com/CVE-2022-41938/): Cross site scripting vulnerability with discussion titles in flarum (critical 9.0)
- [CVE-2019-13183](https://insights.sbomify.com/CVE-2019-13183/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2023-22487](https://insights.sbomify.com/CVE-2023-22487/): Post mentions can be used to read any post on the forum without access control (high 7.7)
- [CVE-2019-11514](https://insights.sbomify.com/CVE-2019-11514/): Flarum mishandles invalidation of user email tokens (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27577 and fix it if it is affected.

What it is: CVE-2023-27577 is a medium-severity vulnerability in flarum framework, published on 10 Mar 2023. 
Exploitation: There is no known exploitation of CVE-2023-27577 in the wild and no public exploit code.

Affected packages and fixed versions:
- flarum/core (Packagist): affected all versions; fixed in 1.7.0
- flarum/core (Packagist): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27577/ (Markdown: https://insights.sbomify.com/CVE-2023-27577/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27577
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27577
- OSV: https://osv.dev/vulnerability/CVE-2023-27577

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27577/
Summaries are generated and may contain mistakes; the official description above is the record.
