# CVE-2023-27581: github-slug-action vulnerable to arbitrary code execution

> Attackers can execute arbitrary code and steal secrets on GitHub runners by injecting payloads into pull request branch names.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-6q4m-7476-932w

## What is CVE-2023-27581?

CVE-2023-27581 is a high-severity command injection vulnerability in rlespinasse github-slug-action, published on 13 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

github-slug-action is a GitHub Action to expose slug value of GitHub environment variables inside of one's GitHub workflow. Starting in version 4.0.0` and prior to version 4.4.1, this action uses the `github.head_ref` parameter in an insecure way. This vulnerability can be triggered by any user on GitHub on any workflow using the action on pull requests. They just need to create a pull request with a branch name, which can contain the attack payload. This can be used to execute code on the GitHub runners and to exfiltrate any secrets one uses in the CI pipeline. A patched action is available in version 4.4.1. No workaround is available.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-27581?

1 open source package ship an affected version, including rlespinasse/github-slug-action. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rlespinasse/github-slug-action` | GitHub Actions | From 4.0.0 | 4.4.1 |

Products: Github-Slug-Action Project Github-Slug-Action.

## How do I fix CVE-2023-27581?

Upgrade rlespinasse/github-slug-action to 4.4.1 or later.

## Is CVE-2023-27581 being exploited?

There is no known exploitation of CVE-2023-27581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27581 and fix it if it is affected.

What it is: CVE-2023-27581 is a high-severity command injection vulnerability in rlespinasse github-slug-action, published on 13 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27581 in the wild and no public exploit code.

Affected packages and fixed versions:
- rlespinasse/github-slug-action (GitHub Actions): affected from 4.0.0; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27581/ (Markdown: https://insights.sbomify.com/CVE-2023-27581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27581
- OSV: https://osv.dev/vulnerability/CVE-2023-27581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27581/
Summaries are generated and may contain mistakes; the official description above is the record.
