{"answers":{"affected":"3 open source packages ship an affected version, including github.com/foxcpp/maddy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27582 in the wild and no public exploit code.","fix":"Upgrade github.com/foxcpp/maddy to 0.6.3 or later.","what":"CVE-2023-27582 is a critical authentication bypass vulnerability in foxcpp maddy, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27582 and fix it if it is affected.\n\nWhat it is: CVE-2023-27582 is a critical authentication bypass vulnerability in foxcpp maddy, published on 13 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27582 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/foxcpp/maddy (Go): affected from 0.2.0; fixed in 0.6.3\n- github.com/foxcpp/maddy (Go): affected from 0.2.0; fixed in 0.6.3\n- github.com/foxcpp/maddy (Go): affected from 0.2.0; fixed in 0.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27582/ (Markdown: https://insights.sbomify.com/CVE-2023-27582/index.md)","id":"CVE-2023-27582","markdown":"https://insights.sbomify.com/CVE-2023-27582/index.md","name":"CVE-2023-27582","record":{"aliases":["GHSA-4g76-w3xw-2x6w","GO-2023-1630"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"maddy mail server","requires_auth":"none","summary":"Attackers can bypass authentication in maddy mail server by specifying a SASL authorization username, gaining unauthorized access to accounts.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"maddy","vendor":"maddy_project"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-305","name":"Authentication Bypass by Primary Weakness"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"maddy is a composable, all-in-one mail server. Starting with version 0.2.0 and prior to version 0.6.3, maddy allows a full authentication bypass if SASL authorization username is specified when using the PLAIN authentication mechanisms. Instead of validating the specified username, it is accepted as is after checking the credentials for the authentication username. maddy 0.6.3 includes the fix for the bug. There are no known workarounds.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Full authentication bypass if SASL authorization username is specified","id":"CVE-2023-27582","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Panindex uses hard coded cyptographic key","id":"CVE-2023-27583"},"packages":[{"ecosystem":"Go","fixed":["0.6.3"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":null,"source":"GHSA-4g76-w3xw-2x6w"},{"ecosystem":"Go","fixed":["0.6.3"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GHSA-4g76-w3xw-2x6w"},{"ecosystem":"Go","fixed":["0.6.3"],"introduced":["0.2.0"],"last_affected":[],"package":"github.com/foxcpp/maddy","purl":"pkg:golang/github.com/foxcpp/maddy","source":"GO-2023-1630"}],"prev":{"headline":"github-slug-action vulnerable to arbitrary code execution","id":"CVE-2023-27581"},"products":["maddy"],"published":"2023-03-13","related":[{"cvss_score":8.2,"headline":"Maddy Mail Server: LDAP Filter Injection via Unsanitized Username","id":"CVE-2026-40193","kev_date_added":null,"published":"2026-04-15"},{"cvss_score":6.3,"headline":"Maddy Mail Server does not implement account expiry","id":"CVE-2022-24732","kev_date_added":null,"published":"2022-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["foxcpp"]},"summary":"Attackers can bypass authentication in maddy mail server by specifying a SASL authorization username, gaining unauthorized access to accounts.","url":"https://insights.sbomify.com/CVE-2023-27582/"}