# CVE-2023-27592: Stored XSS in Miniflux when opening a broken image due to unescaped ServerError in proxy handler

> Attackers can execute arbitrary JavaScript in a victim's browser via crafted RSS feeds, potentially leading to account takeover or admin access.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-mqqg-xjhj-wfgw

## What is CVE-2023-27592?

CVE-2023-27592 is a medium-severity cross-site scripting vulnerability in miniflux v2, published on 17 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Miniflux is a feed reader. Since v2.0.25, Miniflux will automatically proxy images served over HTTP to prevent mixed content errors. 

When an outbound request made by the Go HTTP client fails, the `html.ServerError` is returned unescaped without the expected Content Security Policy header added to valid responses.

By creating an RSS feed item with the inline description containing an `<img>` tag with a `srcset` attribute pointing to an invalid URL like `http:a<script>alert(1)</script>`, we can coerce the proxy handler into an error condition where the invalid URL is returned unescaped and in full.

This results in JavaScript execution on the Miniflux instance as soon as the user is convinced (e.g. by a message in the alt text) to open the broken image.

An attacker can execute arbitrary JavaScript in the context of a victim Miniflux user when they open a broken image in a crafted RSS feed. This can be used to perform actions on the Miniflux instance as that user and gain administrative access to the Miniflux instance if it is reachable and the victim is an administrator.

A patch is available in version 2.0.43. As a workaround sisable image proxy; default value is `http-only`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-27592?

2 open source packages ship an affected version, including miniflux.app/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `miniflux.app/v2` | Go | From 2.0.25 | 2.0.43 |
| `miniflux.app/v2` | Go | From 2.0.25 | 2.0.43 |

Products: Miniflux Project Miniflux.

## How do I fix CVE-2023-27592?

Upgrade miniflux.app/v2 to 2.0.43 or later.

## Is CVE-2023-27592 being exploited?

There is no known exploitation of CVE-2023-27592 in the wild and no public exploit code.

## Other vulnerabilities in miniflux v2

- [CVE-2023-27591](https://insights.sbomify.com/CVE-2023-27591/): Unauthenticated Miniflux user can bypass allowed networks check to obtain Prometheus metrics (high 7.5)
- [CVE-2026-21885](https://insights.sbomify.com/CVE-2026-21885/): Miniflux Media Proxy SSRF via /proxy endpoint allows access to internal network resources (medium 6.5)
- [CVE-2025-67713](https://insights.sbomify.com/CVE-2025-67713/): Miniflux 2 has an Open Redirect via protocol-relative `redirect_url` (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27592 and fix it if it is affected.

What it is: CVE-2023-27592 is a medium-severity cross-site scripting vulnerability in miniflux v2, published on 17 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27592 in the wild and no public exploit code.

Affected packages and fixed versions:
- miniflux.app/v2 (Go): affected from 2.0.25; fixed in 2.0.43
- miniflux.app/v2 (Go): affected from 2.0.25; fixed in 2.0.43

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27592/ (Markdown: https://insights.sbomify.com/CVE-2023-27592/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27592
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27592
- OSV: https://osv.dev/vulnerability/CVE-2023-27592

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27592/
Summaries are generated and may contain mistakes; the official description above is the record.
