CVE-2023-27594 Cilium vulnerable to potential network policy bypass when routing IPv6 traffic
Attackers can bypass network policies by exploiting IPv6 routing misattribution in Cilium when NodePorts are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-27594?
CVE-2023-27594 is a medium-severity vulnerability in cilium, published on 17 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.11.15, 1.12.8, and 1.13.1, under specific conditions, Cilium may misattribute the source IP address of traffic to a cluster, identifying external traffic as coming from the host on which Cilium is running. As a consequence, network policies for that cluster might be bypassed, depending on the specific network policies enabled.
This issue only manifests when Cilium is routing IPv6 traffic and NodePorts are used to route traffic to pods. IPv6 and endpoint routes are both disabled by default.
The problem has been fixed and is available on versions 1.11.15, 1.12.8, and 1.13.1. As a workaround, disable IPv6 routing.
Which versions are affected by CVE-2023-27594?
14 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/cilium/cilium Go | All versions | 1.11.15, 1.12.8, 1.13.1 |
github.com/cilium/cilium Go | All versions | 1.11.15 |
github.com/cilium/cilium Go | All versions | 1.11.15 |
github.com/cilium/cilium Go | From 1.12.0 | 1.12.8 |
github.com/cilium/cilium Go | From 1.12.0 | 1.12.8 |
github.com/cilium/cilium Go | From 1.13.0 | 1.13.1 |
8 more packages
github.com/cilium/cilium Go | From 1.13.0 | 1.13.1 |
cilium Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
cilium-operator Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
cilium-proxy Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
hubble Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
hubble-relay Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
hubble-ui Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
hubble-ui-backend Bitnami | All versions | 1.11.15, 1.12.8, 1.13.1 |
Products include Cilium Cilium.
How do I fix CVE-2023-27594?
Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.11.15, 1.12.8 or 1.13.1.
Is CVE-2023-27594 being exploited?
There is no known exploitation of CVE-2023-27594 in the wild and no public exploit code.
Other vulnerabilities in cilium
- CVE-2026-49445 Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access
- CVE-2022-29178 Incorrect Default Permissions in Cilium
- CVE-2024-28860 Insecure IPsec transport encryption in Cilium
- CVE-2026-41520 Cillium exposes sensitive information included in the cilium-bugtool debug archive
- CVE-2024-37307 Cilium leaks sensitive information in cilium-bugtool
Sources
Also known as BIT-cilium-2023-27594, BIT-cilium-operator-2023-27594, BIT-cilium-proxy-2023-27594, BIT-hubble-2023-27594, BIT-hubble-relay-2023-27594, BIT-hubble-ui-2023-27594 and 3 more.