# CVE-2023-27595: Cilium eBPF filters may be temporarily removed during agent restart

> Attackers can bypass network policies or disrupt connections during Cilium agent restarts due to temporary eBPF program detachment.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-cilium-2023-27595, BIT-cilium-operator-2023-27595, BIT-cilium-proxy-2023-27595, BIT-hubble-2023-27595, BIT-hubble-relay-2023-27595, BIT-hubble-ui-2023-27595, BIT-hubble-ui-backend-2023-27595, GHSA-r5x6-w42p-jhpp, GO-2023-1644

## What is CVE-2023-27595?

CVE-2023-27595 is a medium-severity vulnerability in cilium, published on 17 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. In version 1.13.0, when Cilium is started, there is a short period when Cilium eBPF programs are not attached to the host. During this period, the host does not implement any of Cilium's featureset. This can cause disruption to newly established connections during this period due to the lack of Load Balancing, or can cause Network Policy bypass due to the lack of Network Policy enforcement during the window. This vulnerability impacts any Cilium-managed endpoints on the node (such as Kubernetes Pods), as well as the host network namespace (including Host Firewall). This vulnerability is fixed in Cilium 1.13.1 or later. Cilium releases 1.12.x, 1.11.x, and earlier are not affected. There are no known workarounds.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2023-27595?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.1 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.1 |
| `github.com/cilium/cilium` | Go | From 1.13.0 | 1.13.1 |
| `cilium` | Bitnami | From 1.13.0 | 1.13.1 |
| `cilium-operator` | Bitnami | From 1.13.0 | 1.13.1 |
| `cilium-proxy` | Bitnami | From 1.13.0 to 1.13.0 | None |
| `hubble` | Bitnami | From 1.13.0 to 1.13.0 | None |
| `hubble-relay` | Bitnami | From 1.13.0 | 1.13.1 |
| `hubble-ui` | Bitnami | From 1.13.0 to 1.13.0 | None |
| `hubble-ui-backend` | Bitnami | From 1.13.0 to 1.13.0 | None |

Products: Cilium Cilium.

## How do I fix CVE-2023-27595?

Upgrade github.com/cilium/cilium to 1.13.1 or later.

## Is CVE-2023-27595 being exploited?

There is no known exploitation of CVE-2023-27595 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27595 and fix it if it is affected.

What it is: CVE-2023-27595 is a medium-severity vulnerability in cilium, published on 17 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27595 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.1
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.1
- github.com/cilium/cilium (Go): affected from 1.13.0; fixed in 1.13.1
- cilium (Bitnami): affected from 1.13.0; fixed in 1.13.1
- cilium-operator (Bitnami): affected from 1.13.0; fixed in 1.13.1
- cilium-proxy (Bitnami): affected from 1.13.0 up to 1.13.0; no fix listed
- hubble (Bitnami): affected from 1.13.0 up to 1.13.0; no fix listed
- hubble-relay (Bitnami): affected from 1.13.0; fixed in 1.13.1
- hubble-ui (Bitnami): affected from 1.13.0 up to 1.13.0; no fix listed
- hubble-ui-backend (Bitnami): affected from 1.13.0 up to 1.13.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27595/ (Markdown: https://insights.sbomify.com/CVE-2023-27595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27595
- OSV: https://osv.dev/vulnerability/CVE-2023-27595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27595/
Summaries are generated and may contain mistakes; the official description above is the record.
