CVE-2023-27596 OpenSIPS has vulnerability in the codec_delete_XX() functions

High 7.5 Published Updated

An attacker can crash the OpenSIPS server by sending malformed SDP bodies to configurations using specific codec functions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-27596?

CVE-2023-27596 is a high-severity denial of service vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, OpenSIPS crashes when a malformed SDP body is sent multiple times to an OpenSIPS configuration that makes use of the `stream_process` function. This issue was discovered during coverage guided fuzzing of the function `codec_delete_except_re`. By abusing this vulnerability, an attacker is able to crash the server. It affects configurations containing functions that rely on the affected code, such as the function `codec_delete_except_re`. This issue has been fixed in version 3.1.8 and 3.2.5.

Weakness: CWE-770

Which versions are affected by CVE-2023-27596?

It affects 1 product.

Products include Opensips Opensips.

How do I fix CVE-2023-27596?

No fix has been published for CVE-2023-27596 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-27596 being exploited?

There is no known exploitation of CVE-2023-27596 in the wild and no public exploit code.

Sources

Also known as GHSA-3ghx-j39m-cw4f, UBUNTU-CVE-2023-27596.

Is CVE-2023-27596 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free