CVE-2023-27597 OpenSIPS has vulnerability in the parse_uri() function

High 7.5 Published Updated

A specially crafted SIP message causes a segmentation fault in OpenSIPS, leading to a server crash and denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-27597?

CVE-2023-27597 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.

Weakness: CWE-20

Which versions are affected by CVE-2023-27597?

It affects 1 product.

Products include Opensips Opensips.

How do I fix CVE-2023-27597?

No fix has been published for CVE-2023-27597 yet. Limit exposure of the affected software until one is available.

Is CVE-2023-27597 being exploited?

There is no known exploitation of CVE-2023-27597 in the wild and no public exploit code.

Sources

Also known as GHSA-358f-935m-7p9c, UBUNTU-CVE-2023-27597.

Is CVE-2023-27597 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free