{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27597 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-27597 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-27597 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27597 and fix it if it is affected.\n\nWhat it is: CVE-2023-27597 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27597 in the wild and no public exploit code.\n\nAffected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27597/ (Markdown: https://insights.sbomify.com/CVE-2023-27597/index.md)","id":"CVE-2023-27597","markdown":"https://insights.sbomify.com/CVE-2023-27597/index.md","name":"CVE-2023-27597","record":{"aliases":["GHSA-358f-935m-7p9c","UBUNTU-CVE-2023-27597"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"SIP server","requires_auth":"none","summary":"A specially crafted SIP message causes a segmentation fault in OpenSIPS, leading to a server crash and denial of service.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opensips","vendor":"opensips"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"OpenSIPS has vulnerability in the parse_uri() function","id":"CVE-2023-27597","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"null_dereference","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"OpenSIPS has vulnerability in the parse_via() function","id":"CVE-2023-27598"},"packages":[],"prev":{"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27596"},"products":["opensips"],"published":"2023-03-15","related":[{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27596","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the parse_via() function","id":"CVE-2023-27598","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the parse_to_param() function","id":"CVE-2023-27599","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27600","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27601","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the building the local negative replies","id":"CVE-2023-28095","kev_date_added":null,"published":"2023-03-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["OpenSIPS"]},"summary":"A specially crafted SIP message causes a segmentation fault in OpenSIPS, leading to a server crash and denial of service.","url":"https://insights.sbomify.com/CVE-2023-27597/"}