{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27598 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-27598 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-27598 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27598 and fix it if it is affected.\n\nWhat it is: CVE-2023-27598 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27598 in the wild and no public exploit code.\n\nAffected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27598/ (Markdown: https://insights.sbomify.com/CVE-2023-27598/index.md)","id":"CVE-2023-27598","markdown":"https://insights.sbomify.com/CVE-2023-27598/index.md","name":"CVE-2023-27598","record":{"aliases":["GHSA-wxfg-3gwh-rhvx","UBUNTU-CVE-2023-27598"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"SIP server","requires_auth":"none","summary":"A malformed Via header causes a segmentation fault in OpenSIPS, leading to denial of service if specific configuration functions are used.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opensips","vendor":"opensips"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-908","name":"Use of Uninitialized Resource"}],"description":"OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, sending a malformed `Via` header to OpenSIPS triggers a segmentation fault when the function `calc_tag_suffix` is called. A specially crafted `Via` header, which is deemed correct by the parser, will pass uninitialized strings to the function `MD5StringArray` which leads to the crash. Abuse of this vulnerability leads to Denial of Service due to a crash. Since the uninitialized string points to memory location `0x0`, no further exploitation appears to be possible. No special network privileges are required to perform this attack, as long as the OpenSIPS configuration makes use of functions such as `sl_send_reply` or `sl_gen_totag` that trigger the vulnerable code. This issue has been fixed in versions 3.1.7 and 3.2.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"OpenSIPS has vulnerability in the parse_via() function","id":"CVE-2023-27598","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"null_dereference","year":"2023"},"n_packages":0,"n_references":3,"next":{"headline":"OpenSIPS has vulnerability in the parse_to_param() function","id":"CVE-2023-27599"},"packages":[],"prev":{"headline":"OpenSIPS has vulnerability in the parse_uri() function","id":"CVE-2023-27597"},"products":["opensips"],"published":"2023-03-15","related":[{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27596","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the parse_uri() function","id":"CVE-2023-27597","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the parse_to_param() function","id":"CVE-2023-27599","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27600","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27601","kev_date_added":null,"published":"2023-03-15"},{"cvss_score":7.5,"headline":"OpenSIPS has vulnerability in the building the local negative replies","id":"CVE-2023-28095","kev_date_added":null,"published":"2023-03-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["OpenSIPS"]},"summary":"A malformed Via header causes a segmentation fault in OpenSIPS, leading to denial of service if specific configuration functions are used.","url":"https://insights.sbomify.com/CVE-2023-27598/"}