CVE-2023-27599 OpenSIPS has vulnerability in the parse_to_param() function

High 7.5 Published Updated

An attacker can crash the OpenSIPS server by sending a malformed SIP message, causing a denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-27599?

CVE-2023-27599 is a high-severity denial of service vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

Weakness: CWE-20

Which versions are affected by CVE-2023-27599?

It affects 1 product.

Products include Opensips Opensips.

How do I fix CVE-2023-27599?

No fix has been published for CVE-2023-27599 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-27599 being exploited?

There is no known exploitation of CVE-2023-27599 in the wild and no public exploit code.

Sources

Also known as GHSA-qvj2-vqrg-f5jx, UBUNTU-CVE-2023-27599.

Is CVE-2023-27599 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free