# CVE-2023-27599: OpenSIPS has vulnerability in the parse_to_param() function

> An attacker can crash the OpenSIPS server by sending a malformed SIP message, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-qvj2-vqrg-f5jx, UBUNTU-CVE-2023-27599

## What is CVE-2023-27599?

CVE-2023-27599 is a high-severity denial of service vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-27599?

It affects 1 product.


Products: Opensips Opensips.

## How do I fix CVE-2023-27599?

No fix has been published for CVE-2023-27599 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-27599 being exploited?

There is no known exploitation of CVE-2023-27599 in the wild and no public exploit code.

## Other vulnerabilities in opensips

- [CVE-2023-27596](https://insights.sbomify.com/CVE-2023-27596/): OpenSIPS has vulnerability in the codec_delete_XX() functions (high 7.5)
- [CVE-2023-27597](https://insights.sbomify.com/CVE-2023-27597/): OpenSIPS has vulnerability in the parse_uri() function (high 7.5)
- [CVE-2023-27598](https://insights.sbomify.com/CVE-2023-27598/): OpenSIPS has vulnerability in the parse_via() function (high 7.5)
- [CVE-2023-27600](https://insights.sbomify.com/CVE-2023-27600/): OpenSIPS has vulnerability in the codec_delete_XX() functions (high 7.5)
- [CVE-2023-27601](https://insights.sbomify.com/CVE-2023-27601/): OpenSIPS has vulnerability in the codec_delete_XX() functions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27599 and fix it if it is affected.

What it is: CVE-2023-27599 is a high-severity denial of service vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27599 in the wild and no public exploit code.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27599/ (Markdown: https://insights.sbomify.com/CVE-2023-27599/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27599
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27599
- OSV: https://osv.dev/vulnerability/CVE-2023-27599

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27599/
Summaries are generated and may contain mistakes; the official description above is the record.
