{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.linkis:linkis. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27602 in the wild and no public exploit code.","fix":"Upgrade org.apache.linkis:linkis to 1.3.2 or later.","what":"CVE-2023-27602 is a critical vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27602 and fix it if it is affected.\n\nWhat it is: CVE-2023-27602 is a critical vulnerability in Apache Linkis, published on 10 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27602 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.3.2\n- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27602/ (Markdown: https://insights.sbomify.com/CVE-2023-27602/index.md)","id":"CVE-2023-27602","markdown":"https://insights.sbomify.com/CVE-2023-27602/index.md","name":"CVE-2023-27602","record":{"aliases":["GHSA-x84r-jrqm-3hj8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Linkis","requires_auth":"none","summary":"Attackers can upload malicious files to Apache Linkis, potentially leading to remote code execution, requiring an upgrade or specific configuration changes.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"linkis","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"In Apache Linkis \u003c=1.3.1, The PublicService module uploads files without restrictions on the path to the uploaded files, and file types.\n\nWe recommend users upgrade the version of Linkis to version 1.3.2. \n\nFor versions \n\n\u003c=1.3.1, we suggest turning on the file path check switch in linkis.properties\n\n`wds.linkis.workspace.filesystem.owner.check=true`\n`wds.linkis.workspace.filesystem.path.check=true`","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Linkis publicsercice module unrestricted upload of file","id":"CVE-2023-27602","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"file_upload","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue","id":"CVE-2023-27603"},"packages":[{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.linkis:linkis","purl":null,"source":"GHSA-x84r-jrqm-3hj8"},{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.linkis:linkis","purl":"pkg:maven/org.apache.linkis/linkis","source":"GHSA-x84r-jrqm-3hj8"}],"prev":{"headline":"OpenSIPS has vulnerability in the codec_delete_XX() functions","id":"CVE-2023-27601"},"products":["Apache Linkis"],"published":"2023-04-10","related":[{"cvss_score":9.8,"headline":"Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue","id":"CVE-2023-27603","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":9.8,"headline":"Apache Linkis JDBC EngineCon has a deserialization command execution","id":"CVE-2023-29215","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":9.8,"headline":"Apache Linkis DatasourceManager module has a deserialization command execution","id":"CVE-2023-29216","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":9.1,"headline":"Apache Linkis gateway module token authentication bypass","id":"CVE-2023-27987","kev_date_added":null,"published":"2023-04-10"},{"cvss_score":8.8,"headline":"Apache Linkis Basic management services: Privilege Escalation Attack vulnerability","id":"CVE-2024-27181","kev_date_added":null,"published":"2024-08-02"},{"cvss_score":8.8,"headline":"Apache Linkis DataSource: DataSource Remote code execution vulnerability","id":"CVE-2023-46801","kev_date_added":null,"published":"2024-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Attackers can upload malicious files to Apache Linkis, potentially leading to remote code execution, requiring an upgrade or specific configuration changes.","url":"https://insights.sbomify.com/CVE-2023-27602/"}