{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-apache-sqoop. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27604 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-sqoop to 4.0.0 or later.","what":"CVE-2023-27604 is a high-severity command injection vulnerability in Apache Airflow Sqoop Provider, published on 28 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27604 and fix it if it is affected.\n\nWhat it is: CVE-2023-27604 is a high-severity command injection vulnerability in Apache Airflow Sqoop Provider, published on 28 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27604 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0\n- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27604/ (Markdown: https://insights.sbomify.com/CVE-2023-27604/index.md)","id":"CVE-2023-27604","markdown":"https://insights.sbomify.com/CVE-2023-27604/index.md","name":"CVE-2023-27604","record":{"aliases":["GHSA-g3m9-pr5m-4cvp","PYSEC-2026-1142"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow plugin","requires_auth":"low_privilege","summary":"Authenticated attackers with connection editing permissions can execute arbitrary commands via Sqoop import parameters, leading to remote code execution on the Airflow server.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow_sqoop_provider","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections.\n\n It is recommended to upgrade to a version that is not affected.\nThis issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability","id":"CVE-2023-27604","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":3,"n_references":2,"next":{"headline":"WordPress WP Reroute Email Plugin \u003c= 1.4.6 is vulnerable to SQL Injection","id":"CVE-2023-27605"},"packages":[{"ecosystem":"PyPI","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":null,"source":"GHSA-g3m9-pr5m-4cvp"},{"ecosystem":"PyPI","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","source":"GHSA-g3m9-pr5m-4cvp"},{"ecosystem":"PyPI","fixed":["4.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-sqoop","purl":"pkg:pypi/apache-airflow-providers-apache-sqoop","source":"PYSEC-2026-1142"}],"prev":{"headline":"Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue","id":"CVE-2023-27603"},"products":["Apache Airflow Sqoop Provider"],"published":"2023-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-27","vendors":["Apache Software Foundation"]},"summary":"Authenticated attackers with connection editing permissions can execute arbitrary commands via Sqoop import parameters, leading to remote code execution on the Airflow server.","url":"https://insights.sbomify.com/CVE-2023-27604/"}