# CVE-2023-27604: Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability

> Authenticated attackers with connection editing permissions can execute arbitrary commands via Sqoop import parameters, leading to remote code execution on the Airflow server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2023
- **Updated:** 27 Sep 2024
- **Also known as:** GHSA-g3m9-pr5m-4cvp, PYSEC-2026-1142

## What is CVE-2023-27604?

CVE-2023-27604 is a high-severity command injection vulnerability in Apache Airflow Sqoop Provider, published on 28 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections.

 It is recommended to upgrade to a version that is not affected.
This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-27604?

3 open source packages ship an affected version, including apache-airflow-providers-apache-sqoop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-apache-sqoop` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-apache-sqoop` | PyPI | All versions | 4.0.0 |
| `apache-airflow-providers-apache-sqoop` | PyPI | All versions | 4.0.0 |

Products: Apache Airflow Sqoop Provider.

## How do I fix CVE-2023-27604?

Upgrade apache-airflow-providers-apache-sqoop to 4.0.0 or later.

## Is CVE-2023-27604 being exploited?

There is no known exploitation of CVE-2023-27604 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27604 and fix it if it is affected.

What it is: CVE-2023-27604 is a high-severity command injection vulnerability in Apache Airflow Sqoop Provider, published on 28 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27604 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0
- apache-airflow-providers-apache-sqoop (PyPI): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27604/ (Markdown: https://insights.sbomify.com/CVE-2023-27604/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27604
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27604
- OSV: https://osv.dev/vulnerability/CVE-2023-27604

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27604/
Summaries are generated and may contain mistakes; the official description above is the record.
