{"answers":{"affected":"7 open source packages ship an affected version, including pretix. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27891 in the wild and no public exploit code.","fix":"Upgrade pretix to a fixed version for your release line: 4.15.1, 4.17.1 or 4.16.1.","what":"CVE-2023-27891 is a high-severity authentication bypass vulnerability in n/a, published on 6 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-27891 and fix it if it is affected.\n\nWhat it is: CVE-2023-27891 is a high-severity authentication bypass vulnerability in n/a, published on 6 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-27891 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pretix (PyPI): affected all versions; fixed in 4.15.1\n- pretix (PyPI): affected all versions; fixed in 4.15.1\n- pretix (PyPI): affected all versions; fixed in 4.17.1\n- pretix (PyPI): affected from 4.16.0; fixed in 4.16.1\n- pretix (PyPI): affected from 4.16.0; fixed in 4.16.1\n- pretix (PyPI): affected from 4.17.0; fixed in 4.17.1\n- pretix (PyPI): affected from 4.17.0; fixed in 4.17.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27891/ (Markdown: https://insights.sbomify.com/CVE-2023-27891/index.md)","id":"CVE-2023-27891","markdown":"https://insights.sbomify.com/CVE-2023-27891/index.md","name":"CVE-2023-27891","record":{"aliases":["GHSA-r76w-3wwq-jv6v","PYSEC-2023-42"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"pretix ticketing system","requires_auth":"none","summary":"Attackers can authorize OAuth applications from logged-out sessions, potentially leading to account takeover in pretix.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pretix","vendor":"rami"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"rami.io pretix before 4.17.1 allows OAuth application authorization from a logged-out session. The fixed versions are 4.15.1, 4.16.1, and 4.17.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient Session Expiration in pretix","id":"CVE-2023-27891","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2023"},"n_packages":7,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2023-27892"},"packages":[{"ecosystem":"PyPI","fixed":["4.15.1"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":null,"source":"GHSA-r76w-3wwq-jv6v"},{"ecosystem":"PyPI","fixed":["4.15.1"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"GHSA-r76w-3wwq-jv6v"},{"ecosystem":"PyPI","fixed":["4.17.1"],"introduced":["0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"PYSEC-2023-42"},{"ecosystem":"PyPI","fixed":["4.16.1"],"introduced":["4.16.0"],"last_affected":[],"package":"pretix","purl":null,"source":"GHSA-r76w-3wwq-jv6v"},{"ecosystem":"PyPI","fixed":["4.16.1"],"introduced":["4.16.0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"GHSA-r76w-3wwq-jv6v"},{"ecosystem":"PyPI","fixed":["4.17.1"],"introduced":["4.17.0"],"last_affected":[],"package":"pretix","purl":null,"source":"GHSA-r76w-3wwq-jv6v"},{"ecosystem":"PyPI","fixed":["4.17.1"],"introduced":["4.17.0"],"last_affected":[],"package":"pretix","purl":"pkg:pypi/pretix","source":"GHSA-r76w-3wwq-jv6v"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-27890"},"products":["n/a"],"published":"2023-03-06","related":[{"cvss_score":7.8,"headline":"pretix allows Pillow to parse EPS files","id":"CVE-2023-44464","kev_date_added":null,"published":"2023-09-29"},{"cvss_score":5.3,"headline":"pretix potential IP address spoofing vulnerability","id":"CVE-2023-44463","kev_date_added":null,"published":"2023-10-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-06","vendors":["n/a"]},"summary":"Attackers can authorize OAuth applications from logged-out sessions, potentially leading to account takeover in pretix.","url":"https://insights.sbomify.com/CVE-2023-27891/"}