CVE-2023-27898 Cross-site Scripting vulnerability in Jenkins
Attackers can inject malicious scripts via plugin dependency versions, leading to stored XSS in Jenkins error messages.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-27898?
CVE-2023-27898 is a critical cross-site scripting vulnerability in Jenkins Jenkins, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.
Weakness: CWE-79
Which versions are affected by CVE-2023-27898?
5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.375.4 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.375.4 |
org.jenkins-ci.main:jenkins-core Maven | From 2.376 | 2.394 |
org.jenkins-ci.main:jenkins-core Maven | From 2.376 | 2.394 |
jenkins Bitnami | From 2.270.0 | 2.394.0 |
Products include Jenkins Jenkins.
How do I fix CVE-2023-27898?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.375.4 or 2.394.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-27898 being exploited?
There is no known exploitation of CVE-2023-27898 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2023-27898, GHSA-j664-qhh4-hpf8.