{"answers":{"affected":"5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27898 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.375.4 or 2.394.","what":"CVE-2023-27898 is a critical cross-site scripting vulnerability in Jenkins Jenkins, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-27898 and fix it if it is affected.\n\nWhat it is: CVE-2023-27898 is a critical cross-site scripting vulnerability in Jenkins Jenkins, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-27898 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.394\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.394\n- jenkins (Bitnami): affected from 2.270.0; fixed in 2.394.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27898/ (Markdown: https://insights.sbomify.com/CVE-2023-27898/index.md)","id":"CVE-2023-27898","markdown":"https://insights.sbomify.com/CVE-2023-27898/index.md","name":"CVE-2023-27898","record":{"aliases":["BIT-jenkins-2023-27898","GHSA-j664-qhh4-hpf8"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins automation server","requires_auth":"none","summary":"Attackers can inject malicious scripts via plugin dependency versions, leading to stored XSS in Jenkins error messages.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"jenkins","vendor":"jenkins"}],"cvss":{"score":9.6,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting vulnerability in Jenkins","id":"CVE-2023-27898","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"jenkins:jenkins","products":["jenkins:jenkins"],"type":"xss","year":"2023"},"n_packages":5,"n_references":1,"next":{"headline":"Incorrect Authorization in Jenkins Core","id":"CVE-2023-27899"},"packages":[{"ecosystem":"Bitnami","fixed":["2.394.0"],"introduced":["2.270.0"],"last_affected":[],"package":"jenkins","purl":"pkg:bitnami/jenkins","source":"BIT-jenkins-2023-27898"},{"ecosystem":"Maven","fixed":["2.375.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-j664-qhh4-hpf8"},{"ecosystem":"Maven","fixed":["2.375.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-j664-qhh4-hpf8"},{"ecosystem":"Maven","fixed":["2.394"],"introduced":["2.376"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-j664-qhh4-hpf8"},{"ecosystem":"Maven","fixed":["2.394"],"introduced":["2.376"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-j664-qhh4-hpf8"}],"prev":{"headline":"Code Injection vulnerability in SAP CRM","id":"CVE-2023-27897"},"products":["Jenkins"],"published":"2023-03-08","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-28","vendors":["Jenkins Project"]},"summary":"Attackers can inject malicious scripts via plugin dependency versions, leading to stored XSS in Jenkins error messages.","url":"https://insights.sbomify.com/CVE-2023-27898/"}