# CVE-2023-27898: Cross-site Scripting vulnerability in Jenkins

> Attackers can inject malicious scripts via plugin dependency versions, leading to stored XSS in Jenkins error messages.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Mar 2023
- **Updated:** 28 Feb 2025
- **Also known as:** BIT-jenkins-2023-27898, GHSA-j664-qhh4-hpf8

## What is CVE-2023-27898?

CVE-2023-27898 is a critical cross-site scripting vulnerability in Jenkins Jenkins, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-27898?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.375.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.375.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.376 | 2.394 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.376 | 2.394 |
| `jenkins` | Bitnami | From 2.270.0 | 2.394.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-27898?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.375.4 or 2.394.

## Is CVE-2023-27898 being exploited?

There is no known exploitation of CVE-2023-27898 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27898 and fix it if it is affected.

What it is: CVE-2023-27898 is a critical cross-site scripting vulnerability in Jenkins Jenkins, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27898 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.394
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.394
- jenkins (Bitnami): affected from 2.270.0; fixed in 2.394.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27898/ (Markdown: https://insights.sbomify.com/CVE-2023-27898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27898
- OSV: https://osv.dev/vulnerability/CVE-2023-27898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27898/
Summaries are generated and may contain mistakes; the official description above is the record.
