# CVE-2023-27903: Incorrect Authorization in Jenkins Core

> Attackers with local file system access can read or modify temporary files during CLI file uploads due to insecure permissions and race conditions.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2023
- **Updated:** 28 Feb 2025
- **Also known as:** BIT-jenkins-2023-27903, GHSA-584m-7r4m-8j6v

## What is CVE-2023-27903?

CVE-2023-27903 is a medium-severity vulnerability in Jenkins Jenkins, published on 8 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins 2.393 and earlier, LTS 2.375.3 and earlier creates a temporary file in the default temporary directory with the default permissions for newly created files when uploading a file parameter through the CLI, potentially allowing attackers with access to the Jenkins controller file system to read and write the file before it is used.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2023-27903?

7 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.375.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.375.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.376 | 2.387.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.376 | 2.387.1 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.388 | 2.394 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.388 | 2.394 |
| `jenkins` | Bitnami | All versions | 2.394.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2023-27903?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.375.4, 2.387.1 or 2.394.

## Is CVE-2023-27903 being exploited?

There is no known exploitation of CVE-2023-27903 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27903 and fix it if it is affected.

What it is: CVE-2023-27903 is a medium-severity vulnerability in Jenkins Jenkins, published on 8 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-27903 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.375.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.387.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.376; fixed in 2.387.1
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.388; fixed in 2.394
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.388; fixed in 2.394
- jenkins (Bitnami): affected all versions; fixed in 2.394.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27903/ (Markdown: https://insights.sbomify.com/CVE-2023-27903/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27903
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27903
- OSV: https://osv.dev/vulnerability/CVE-2023-27903

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27903/
Summaries are generated and may contain mistakes; the official description above is the record.
