{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci:update-center2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-27905 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci:update-center2 to 3.15 or later.","what":"CVE-2023-27905 is a critical cross-site scripting vulnerability in Jenkins update-center2, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-27905 and fix it if it is affected.\n\nWhat it is: CVE-2023-27905 is a critical cross-site scripting vulnerability in Jenkins update-center2, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-27905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci:update-center2 (Maven): affected from 3.13; fixed in 3.15\n- org.jenkins-ci:update-center2 (Maven): affected from 3.13; fixed in 3.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-27905/ (Markdown: https://insights.sbomify.com/CVE-2023-27905/index.md)","id":"CVE-2023-27905","markdown":"https://insights.sbomify.com/CVE-2023-27905/index.md","name":"CVE-2023-27905","record":{"aliases":["GHSA-pqg3-xfx2-fmqp"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins update center","requires_auth":"none","summary":"Attackers can inject malicious scripts into Jenkins plugin index pages, potentially compromising user sessions and executing code in the browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"update-center2","vendor":"jenkins"}],"cvss":{"score":9.6,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting vulnerability in update-center2","id":"CVE-2023-27905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":1,"next":{"headline":"Memory corruption in Autodesk Maya USD Plugin","id":"CVE-2023-27906"},"packages":[{"ecosystem":"Maven","fixed":["3.15"],"introduced":["3.13"],"last_affected":[],"package":"org.jenkins-ci:update-center2","purl":null,"source":"GHSA-pqg3-xfx2-fmqp"},{"ecosystem":"Maven","fixed":["3.15"],"introduced":["3.13"],"last_affected":[],"package":"org.jenkins-ci:update-center2","purl":"pkg:maven/org.jenkins-ci/update-center2","source":"GHSA-pqg3-xfx2-fmqp"}],"prev":{"headline":"Information disclosure through error stack traces related to agents","id":"CVE-2023-27904"},"products":["Jenkins update-center2"],"published":"2023-03-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-28","vendors":["Jenkins Project"]},"summary":"Attackers can inject malicious scripts into Jenkins plugin index pages, potentially compromising user sessions and executing code in the browser.","url":"https://insights.sbomify.com/CVE-2023-27905/"}