# CVE-2023-27905: Cross site scripting vulnerability in update-center2

> Attackers can inject malicious scripts into Jenkins plugin index pages, potentially compromising user sessions and executing code in the browser.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Mar 2023
- **Updated:** 28 Feb 2025
- **Also known as:** GHSA-pqg3-xfx2-fmqp

## What is CVE-2023-27905?

CVE-2023-27905 is a critical cross-site scripting vulnerability in Jenkins update-center2, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins update-center2 3.13 and 3.14 renders the required Jenkins core version on plugin download index pages without sanitization, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide a plugin for hosting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-27905?

2 open source packages ship an affected version, including org.jenkins-ci:update-center2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci:update-center2` | Maven | From 3.13 | 3.15 |
| `org.jenkins-ci:update-center2` | Maven | From 3.13 | 3.15 |

Products: Jenkins Update-Center2.

## How do I fix CVE-2023-27905?

Upgrade org.jenkins-ci:update-center2 to 3.15 or later.

## Is CVE-2023-27905 being exploited?

There is no known exploitation of CVE-2023-27905 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27905 and fix it if it is affected.

What it is: CVE-2023-27905 is a critical cross-site scripting vulnerability in Jenkins update-center2, published on 8 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27905 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci:update-center2 (Maven): affected from 3.13; fixed in 3.15
- org.jenkins-ci:update-center2 (Maven): affected from 3.13; fixed in 3.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27905/ (Markdown: https://insights.sbomify.com/CVE-2023-27905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27905
- OSV: https://osv.dev/vulnerability/CVE-2023-27905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27905/
Summaries are generated and may contain mistakes; the official description above is the record.
