# CVE-2023-27923: Cross-site scripting in VK Blocks and VK Blocks Pro

> An authenticated attacker can inject arbitrary scripts via the Tag edit function in VK Blocks, potentially compromising user sessions.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 23 May 2023
- **Updated:** 17 Jan 2025
- **Also known as:** GHSA-47m3-mrjf-h78g

## What is CVE-2023-27923?

CVE-2023-27923 is a medium-severity cross-site scripting vulnerability in Vektor,Inc. VK Blocks and VK Blocks Pro, published on 23 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting vulnerability in Tag edit function of VK Blocks 1.53.0.1 and earlier and VK Blocks Pro 1.53.0.1 and earlier allows a remote authenticated attacker to inject an arbitrary script.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-27923?

It affects 1 product.


Products: Vektor-Inc Vk Blocks.

## How do I fix CVE-2023-27923?

No fix has been published for CVE-2023-27923 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-27923 being exploited?

There is no known exploitation of CVE-2023-27923 in the wild and no public exploit code.

## Other vulnerabilities in Vektor,Inc. VK Blocks and VK Blocks Pro

- [CVE-2023-5706](https://insights.sbomify.com/CVE-2023-5706/): VK Blocks <= 1.63.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Block (medium 6.4)
- [CVE-2023-27925](https://insights.sbomify.com/CVE-2023-27925/): Cross-site scripting in VK Blocks and VK Blocks Pro (medium 5.4)
- [CVE-2023-0583](https://insights.sbomify.com/CVE-2023-0583/): VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update (medium 4.3)
- [CVE-2023-0584](https://insights.sbomify.com/CVE-2023-0584/): VK Blocks <= 1.57.0.5 - Authenticated(Contributor+) Settings Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27923 and fix it if it is affected.

What it is: CVE-2023-27923 is a medium-severity cross-site scripting vulnerability in Vektor,Inc. VK Blocks and VK Blocks Pro, published on 23 May 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-27923 in the wild and no public exploit code.

Affected product: Vektor,Inc. VK Blocks and VK Blocks Pro. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27923/ (Markdown: https://insights.sbomify.com/CVE-2023-27923/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27923
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27923
- OSV: https://osv.dev/vulnerability/CVE-2023-27923

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27923/
Summaries are generated and may contain mistakes; the official description above is the record.
