{"answers":{"affected":"2 open source packages ship an affected version, including org.htmlunit:htmlunit. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-2798 in the wild and no public exploit code.","fix":"Upgrade org.htmlunit:htmlunit to 2.70.0 or later.","what":"CVE-2023-2798 is a high-severity denial of service vulnerability in htmlunit:htmlunit, published on 25 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-2798 and fix it if it is affected.\n\nWhat it is: CVE-2023-2798 is a high-severity denial of service vulnerability in htmlunit:htmlunit, published on 25 May 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-2798 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.htmlunit:htmlunit (Maven): affected all versions; fixed in 2.70.0\n- org.htmlunit:htmlunit (Maven): affected all versions; fixed in 2.70.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-2798/ (Markdown: https://insights.sbomify.com/CVE-2023-2798/index.md)","id":"CVE-2023-2798","markdown":"https://insights.sbomify.com/CVE-2023-2798/index.md","name":"CVE-2023-2798","record":{"aliases":["GHSA-rc44-5cmh-879m","UBUNTU-CVE-2023-2798"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web browser library","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering a stack overflow in HtmlUnit when browsing untrusted webpages.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Google","cpe":[{"product":"htmlunit","vendor":"htmlunit"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Those using HtmlUnit to browse untrusted webpages may be vulnerable to Denial of service attacks (DoS). If HtmlUnit is running on user supplied web pages, an attacker may supply content that causes HtmlUnit to crash by a stack overflow. This effect may support a denial of service attack.This issue affects htmlunit before 2.70.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in HtmlUnit","id":"CVE-2023-2798","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":2,"next":{"headline":"cnoa OA hard-coded password","id":"CVE-2023-2799"},"packages":[{"ecosystem":"Maven","fixed":["2.70.0"],"introduced":["0"],"last_affected":[],"package":"org.htmlunit:htmlunit","purl":null,"source":"GHSA-rc44-5cmh-879m"},{"ecosystem":"Maven","fixed":["2.70.0"],"introduced":["0"],"last_affected":[],"package":"org.htmlunit:htmlunit","purl":"pkg:maven/org.htmlunit/htmlunit","source":"GHSA-rc44-5cmh-879m"}],"prev":{"headline":"Path traversal in GitHub plugin's code preview feature","id":"CVE-2023-2797"},"products":["htmlunit:htmlunit"],"published":"2023-05-25","related":[{"cvss_score":9.8,"headline":"HtmlUnit vulnerable to Remote Code Execution (RCE) via XSTL","id":"CVE-2023-49093","kev_date_added":null,"published":"2023-12-04"},{"cvss_score":9.8,"headline":"HtmlUnit Code Injection vulnerability","id":"CVE-2023-26119","kev_date_added":null,"published":"2023-04-03"},{"cvss_score":7.5,"headline":"OutOfMemory Exception by specifically crafted processing instruction in NekoHtml Parser","id":"CVE-2022-29546","kev_date_added":null,"published":"2022-04-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-02","vendors":["htmlunit"]},"summary":"An attacker can cause a denial of service by triggering a stack overflow in HtmlUnit when browsing untrusted webpages.","url":"https://insights.sbomify.com/CVE-2023-2798/"}