CVE-2023-27986 emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code injections through a crafted mailto: URI with unescaped
High 7.8
Published
Updated
Check this codebase for CVE-2023-27986 and fix it if it is affected.
What it is: CVE-2023-27986 is a high-severity vulnerability in n/a, published on 9 Mar 2023.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27986 exists.
Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2023-27986/ (Markdown: https://insights.sbomify.com/CVE-2023-27986/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2023-27986?
CVE-2023-27986 is a high-severity vulnerability in n/a, published on 9 Mar 2023.
Official description
emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code injections through a crafted mailto: URI with unescaped double-quote characters. It is fixed in 29.0.90.
Weakness: CWE-94
Which versions are affected by CVE-2023-27986?
It affects 1 product.
Products include Gnu Emacs.
How do I fix CVE-2023-27986?
Upgrade to a fixed version.
Is CVE-2023-27986 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27986 exists.
Other vulnerabilities in n/a
Sources
Also known as AZL-25603, CLEANSTART-2024-EW88000, DEBIAN-CVE-2023-27986, GHSA-whwp-m746-hx6w, UBUNTU-CVE-2023-27986.