# CVE-2023-27986: emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code injections through a crafted mailto: URI with unescaped


- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Mar 2023
- **Updated:** 5 Mar 2025
- **Also known as:** AZL-25603, CLEANSTART-2024-EW88000, DEBIAN-CVE-2023-27986, GHSA-whwp-m746-hx6w, UBUNTU-CVE-2023-27986

## What is CVE-2023-27986?

CVE-2023-27986 is a high-severity vulnerability in n/a, published on 9 Mar 2023. 

### Official description

emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code injections through a crafted mailto: URI with unescaped double-quote characters. It is fixed in 29.0.90.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2023-27986?

It affects 1 product.


Products: Gnu Emacs.

## How do I fix CVE-2023-27986?

Upgrade to a fixed version.

## Is CVE-2023-27986 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27986 exists.

## Other vulnerabilities in n/a

- [CVE-2007-6109](https://insights.sbomify.com/CVE-2007-6109/): Memory corruption in n/a (critical 10.0)
- [CVE-2024-39331](https://insights.sbomify.com/CVE-2024-39331/): Code injection in n/a (critical 9.8)
- [CVE-2024-53920](https://insights.sbomify.com/CVE-2024-53920/): Code injection in n/a (high 7.8)
- [CVE-2024-30202](https://insights.sbomify.com/CVE-2024-30202/): Code injection in n/a (high 7.8)
- [CVE-2023-2491](https://insights.sbomify.com/CVE-2023-2491/): Command injection in emacs (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-27986 and fix it if it is affected.

What it is: CVE-2023-27986 is a high-severity vulnerability in n/a, published on 9 Mar 2023. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-27986 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-27986/ (Markdown: https://insights.sbomify.com/CVE-2023-27986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-27986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-27986
- OSV: https://osv.dev/vulnerability/CVE-2023-27986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-27986/
Summaries are generated and may contain mistakes; the official description above is the record.
