CVE-2023-28097 OpenSIPS has vulnerability in the Content-Length Parser

High 7.5 Published Updated

A malformed SIP message with a large Content-Length value causes a segmentation fault in OpenSIPS, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2023-28097?

CVE-2023-28097 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large _Content-Length_ value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.

Weakness: CWE-190

Which versions are affected by CVE-2023-28097?

It affects 1 product.

Products include Opensips Opensips.

How do I fix CVE-2023-28097?

No fix has been published for CVE-2023-28097 yet. Limit exposure of the affected software until one is available.

Is CVE-2023-28097 being exploited?

There is no known exploitation of CVE-2023-28097 in the wild and no public exploit code.

Sources

Also known as GHSA-c6j5-f4h4-2xrq, UBUNTU-CVE-2023-28097.

Is CVE-2023-28097 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free