# CVE-2023-28097: OpenSIPS has vulnerability in the Content-Length Parser

> A malformed SIP message with a large Content-Length value causes a segmentation fault in OpenSIPS, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-c6j5-f4h4-2xrq, UBUNTU-CVE-2023-28097

## What is CVE-2023-28097?

CVE-2023-28097 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large _Content-Length_ value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2023-28097?

It affects 1 product.


Products: Opensips Opensips.

## How do I fix CVE-2023-28097?

No fix has been published for CVE-2023-28097 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28097 being exploited?

There is no known exploitation of CVE-2023-28097 in the wild and no public exploit code.

## Other vulnerabilities in opensips

- [CVE-2023-27596](https://insights.sbomify.com/CVE-2023-27596/): OpenSIPS has vulnerability in the codec_delete_XX() functions (high 7.5)
- [CVE-2023-27597](https://insights.sbomify.com/CVE-2023-27597/): OpenSIPS has vulnerability in the parse_uri() function (high 7.5)
- [CVE-2023-27598](https://insights.sbomify.com/CVE-2023-27598/): OpenSIPS has vulnerability in the parse_via() function (high 7.5)
- [CVE-2023-27599](https://insights.sbomify.com/CVE-2023-27599/): OpenSIPS has vulnerability in the parse_to_param() function (high 7.5)
- [CVE-2023-27600](https://insights.sbomify.com/CVE-2023-27600/): OpenSIPS has vulnerability in the codec_delete_XX() functions (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28097 and fix it if it is affected.

What it is: CVE-2023-28097 is a high-severity vulnerability in opensips, published on 15 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28097 in the wild and no public exploit code.

Affected product: opensips. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28097/ (Markdown: https://insights.sbomify.com/CVE-2023-28097/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28097
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28097
- OSV: https://osv.dev/vulnerability/CVE-2023-28097

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28097/
Summaries are generated and may contain mistakes; the official description above is the record.
