# CVE-2023-28102: Command injection in discordrb

> Attackers can execute arbitrary shell commands if user input reaches the vulnerable encoder method in the discordrb Ruby library.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2023
- **Updated:** 19 Feb 2025
- **Also known as:** GHSA-8832-4mm5-x2r6

## What is CVE-2023-28102?

CVE-2023-28102 is a high-severity command injection vulnerability in shardlab discordrb, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

discordrb is an implementation of the Discord API using Ruby. In discordrb before commit `91e13043ffa` the `encoder.rb` file unsafely constructs a shell string using the file parameter, which can potentially leave clients of discordrb vulnerable to command injection. The library is not directly exploitable: the exploit requires that some client of the library calls the vulnerable method with user input. However, if unsafe input reaches the library method, then an attacker can execute arbitrary shell commands on the host machine. Full impact will depend on the permissions of the process running the `discordrb` library and will likely not be total system access. This issue has been addressed in code, but a new release of the `discordrb` gem has not been uploaded to rubygems. This issue is also tracked as `GHSL-2022-094`.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2023-28102?

2 open source packages ship an affected version, including discordrb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discordrb` | RubyGems | All versions | 3.4.3 |
| `discordrb` | RubyGems | All versions | 3.4.3 |

Products: Discordrb Project Discordrb.

## How do I fix CVE-2023-28102?

Upgrade discordrb to 3.4.3 or later.

## Is CVE-2023-28102 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28102 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28102 and fix it if it is affected.

What it is: CVE-2023-28102 is a high-severity command injection vulnerability in shardlab discordrb, published on 27 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-28102 exists.

Affected packages and fixed versions:
- discordrb (RubyGems): affected all versions; fixed in 3.4.3
- discordrb (RubyGems): affected all versions; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28102/ (Markdown: https://insights.sbomify.com/CVE-2023-28102/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28102
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28102
- OSV: https://osv.dev/vulnerability/CVE-2023-28102

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28102/
Summaries are generated and may contain mistakes; the official description above is the record.
