# CVE-2023-28105: Go-huge-util vulnerable to path traversal when unzipping files

> Attackers can exploit path traversal in the Go-huge-util library to write files outside the intended directory when unzipping malicious archives.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-5g39-ppwg-6xx8, GO-2023-1640

## What is CVE-2023-28105?

CVE-2023-28105 is a high-severity path traversal vulnerability in dablelv go-huge-util, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

go-used-util has commonly used utility functions for Go. Versions prior to 0.0.34 have a ZipSlip issue when using fsutil package to unzip files. When users use `zip.Unzip` to unzip zip files from a malicious attacker, they may be vulnerable to path traversal. The issue has been fixed in version 0.0.34. There are no known workarounds.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2023-28105?

3 open source packages ship an affected version, including github.com/dablelv/go-huge-util. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/dablelv/go-huge-util` | Go | All versions | 0.0.34 |
| `github.com/dablelv/go-huge-util` | Go | All versions | 0.0.34 |
| `github.com/dablelv/go-huge-util` | Go | All versions | 0.0.34 |

Products: Go-Huge-Util Project Go-Huge-Util.

## How do I fix CVE-2023-28105?

Upgrade github.com/dablelv/go-huge-util to 0.0.34 or later.

## Is CVE-2023-28105 being exploited?

There is no known exploitation of CVE-2023-28105 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28105 and fix it if it is affected.

What it is: CVE-2023-28105 is a high-severity path traversal vulnerability in dablelv go-huge-util, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28105 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/dablelv/go-huge-util (Go): affected all versions; fixed in 0.0.34
- github.com/dablelv/go-huge-util (Go): affected all versions; fixed in 0.0.34
- github.com/dablelv/go-huge-util (Go): affected all versions; fixed in 0.0.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28105/ (Markdown: https://insights.sbomify.com/CVE-2023-28105/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28105
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28105
- OSV: https://osv.dev/vulnerability/CVE-2023-28105

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28105/
Summaries are generated and may contain mistakes; the official description above is the record.
