CVE-2023-28107 Discourse vulnerable to multisite DoS by spamming backups
Administrators can cause denial of service by spamming backup requests, exhausting database connections and affecting the entire multisite cluster.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-28107?
CVE-2023-28107 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 17 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. Prior to version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches, a user logged as an administrator can request backups multiple times, which will eat up all the connections to the DB. If this is done on a site using multisite, then it can affect the whole cluster. The vulnerability is patched in version 3.0.2 of the `stable` branch and version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Weakness: CWE-770
Which versions are affected by CVE-2023-28107?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | All versions to 3.0.1 | 3.1.0 |
Products include Discourse Discourse.
How do I fix CVE-2023-28107?
Upgrade discourse to 3.1.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-28107 being exploited?
There is no known exploitation of CVE-2023-28107 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2023-28107, GHSA-cp7c-fm4c-6xxx.