# CVE-2023-28108: Pimcore has improper quoting of columns when calling methods "getByUuid" & "exists" on UUID Model

> Attackers can inject SQL via improper quoting in UUID model methods if developers pass unvalidated input, requiring an upgrade to Pimcore.

- **Severity:** High 7.9 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-xc9p-r5qj-8xm9

## What is CVE-2023-28108?

CVE-2023-28108 is a high-severity SQL injection vulnerability in Pimcore Pimcore, published on 16 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Pimcore is an open source data and experience management platform. Prior to version 10.5.19, quoting is not done properly in UUID DAO model. There is the theoretical possibility to inject custom SQL if the developer is using this methods with input data and not doing proper input validation in advance and so relies on the auto-quoting being done by the DAO class. Users should update to version 10.5.19 to receive a patch or, as a workaround, apply the patch manually.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2023-28108?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.5.19 |
| `pimcore/pimcore` | Packagist | All versions | 10.5.19 |

Products: Pimcore Pimcore.

## How do I fix CVE-2023-28108?

Upgrade pimcore/pimcore to 10.5.19 or later.

## Is CVE-2023-28108 being exploited?

There is no known exploitation of CVE-2023-28108 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28108 and fix it if it is affected.

What it is: CVE-2023-28108 is a high-severity SQL injection vulnerability in Pimcore Pimcore, published on 16 Mar 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28108 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.19
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.5.19

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28108/ (Markdown: https://insights.sbomify.com/CVE-2023-28108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28108
- OSV: https://osv.dev/vulnerability/CVE-2023-28108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28108/
Summaries are generated and may contain mistakes; the official description above is the record.
