{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-28110 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2023-28110 yet. Limit exposure of the affected software until one is available.","what":"CVE-2023-28110 is a medium-severity command injection vulnerability in jumpserver, published on 16 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-28110 and fix it if it is affected.\n\nWhat it is: CVE-2023-28110 is a medium-severity command injection vulnerability in jumpserver, published on 16 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-28110 in the wild and no public exploit code.\n\nAffected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-28110/ (Markdown: https://insights.sbomify.com/CVE-2023-28110/index.md)","id":"CVE-2023-28110","markdown":"https://insights.sbomify.com/CVE-2023-28110/index.md","name":"CVE-2023-28110","record":{"aliases":["GHSA-6x5p-jm59-jh29"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JumpServer Koko component","requires_auth":"high_privilege","summary":"Attackers can execute dangerous commands in the Koko container environment by using illegal tokens to connect to Kubernetes clusters.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jumpserver","vendor":"fit2cloud"},{"product":"koko","vendor":"fit2cloud"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"JumpServer Koko vulnerable to Command Injection for Kubernetes Connection","id":"CVE-2023-28110","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2023"},"n_packages":0,"n_references":2,"next":{"headline":"Discourse vulnerable to SSRF protection bypass possible with IPv4-mapped IPv6 addresses","id":"CVE-2023-28111"},"packages":[],"prev":{"headline":"Play With Docker vulnerable to Authorization Bypass Through User-Controlled Key","id":"CVE-2023-28109"},"products":["jumpserver"],"published":"2023-03-16","related":[{"cvss_score":10,"headline":"Arbitrary File Read in Ansible Playbooks in Jumpserver","id":"CVE-2024-40628","kev_date_added":null,"published":"2024-07-18"},{"cvss_score":10,"headline":"Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver","id":"CVE-2024-40629","kev_date_added":null,"published":"2024-07-18"},{"cvss_score":10,"headline":"JumpServer's insecure Ansible playbook validation leads to RCE in Celery","id":"CVE-2024-29201","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":10,"headline":"JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery","id":"CVE-2024-29202","kev_date_added":null,"published":"2024-03-29"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2023-48193","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":9.6,"headline":"JumpServer Connection Token Leak Vulnerability","id":"CVE-2025-62712","kev_date_added":null,"published":"2025-10-30"},{"cvss_score":8.9,"headline":"Path traversal in Jumpserver","id":"CVE-2023-42819","kev_date_added":null,"published":"2023-09-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-25","vendors":["jumpserver"]},"summary":"Attackers can execute dangerous commands in the Koko container environment by using illegal tokens to connect to Kubernetes clusters.","url":"https://insights.sbomify.com/CVE-2023-28110/"}