# CVE-2023-28110: JumpServer Koko vulnerable to Command Injection for Kubernetes Connection

> Attackers can execute dangerous commands in the Koko container environment by using illegal tokens to connect to Kubernetes clusters.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 16 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** GHSA-6x5p-jm59-jh29

## What is CVE-2023-28110?

CVE-2023-28110 is a medium-severity command injection vulnerability in jumpserver, published on 16 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Jumpserver is a popular open source bastion host, and Koko is a Jumpserver component that is the Go version of coco, refactoring coco's SSH/SFTP service and Web Terminal service. Prior to version 2.28.8, using illegal tokens to connect to a Kubernetes cluster through Koko can result in the execution of dangerous commands that may disrupt the Koko container environment and affect normal usage. The vulnerability has been fixed in v2.28.8.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2023-28110?

It affects 2 products.


Products: Fit2cloud Jumpserver, Fit2cloud Koko.

## How do I fix CVE-2023-28110?

No fix has been published for CVE-2023-28110 yet. Limit exposure of the affected software until one is available.

## Is CVE-2023-28110 being exploited?

There is no known exploitation of CVE-2023-28110 in the wild and no public exploit code.

## Other vulnerabilities in jumpserver

- [CVE-2024-40628](https://insights.sbomify.com/CVE-2024-40628/): Arbitrary File Read in Ansible Playbooks in Jumpserver (critical 10.0)
- [CVE-2024-40629](https://insights.sbomify.com/CVE-2024-40629/): Arbitrary File Write in Ansible Playbooks leads to RCE in Jumpserver (critical 10.0)
- [CVE-2024-29201](https://insights.sbomify.com/CVE-2024-29201/): JumpServer's insecure Ansible playbook validation leads to RCE in Celery (critical 10.0)
- [CVE-2024-29202](https://insights.sbomify.com/CVE-2024-29202/): JumpServer vulnerable to Jinja2 template injection in Ansible leads to RCE in Celery (critical 10.0)
- [CVE-2023-48193](https://insights.sbomify.com/CVE-2023-48193/): Security feature bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28110 and fix it if it is affected.

What it is: CVE-2023-28110 is a medium-severity command injection vulnerability in jumpserver, published on 16 Mar 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-28110 in the wild and no public exploit code.

Affected product: jumpserver. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28110/ (Markdown: https://insights.sbomify.com/CVE-2023-28110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28110
- OSV: https://osv.dev/vulnerability/CVE-2023-28110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28110/
Summaries are generated and may contain mistakes; the official description above is the record.
