# CVE-2023-28112: Discourse's SSRF protection missing for some FastImage requests

> Attackers can trigger outbound connections to private IPs via FastImage requests, bypassing SSRF protections in Discourse.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Mar 2023
- **Updated:** 25 Feb 2025
- **Also known as:** BIT-discourse-2023-28112, GHSA-9897-x229-55gh

## What is CVE-2023-28112?

CVE-2023-28112 is a medium-severity server-side request forgery vulnerability in Discourse Discourse, published on 17 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, some user provided URLs were being passed to FastImage without SSRF protection. Insufficient protections could enable attackers to trigger outbound network connections from the Discourse server to private IP addresses. This affects any site running the `tests-passed` or `beta` branches versions 3.1.0.beta2 and prior. This issue is patched in version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2023-28112?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.1.0 |

Products: Discourse Discourse.

## How do I fix CVE-2023-28112?

Upgrade discourse to 3.1.0 or later.

## Is CVE-2023-28112 being exploited?

There is no known exploitation of CVE-2023-28112 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-28112 and fix it if it is affected.

What it is: CVE-2023-28112 is a medium-severity server-side request forgery vulnerability in Discourse Discourse, published on 17 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-28112 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-28112/ (Markdown: https://insights.sbomify.com/CVE-2023-28112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-28112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-28112
- OSV: https://osv.dev/vulnerability/CVE-2023-28112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-28112/
Summaries are generated and may contain mistakes; the official description above is the record.
