CVE-2023-28113 russh may use insecure Diffie-Hellman keys
Insufficient Diffie-Hellman key validation in russh allows eavesdropping on SSH connections, compromising confidentiality.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-28113?
CVE-2023-28113 is a medium-severity vulnerability in warp-tech russh, published on 16 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1
Which versions are affected by CVE-2023-28113?
4 open source packages ship an affected version, including russh. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
russh crates.io | All versions | 0.36.2 |
russh crates.io | All versions | 0.36.2 |
russh crates.io | From 0.37.0 | 0.37.1 |
russh crates.io | From 0.37.0 | 0.37.1 |
Products include Russh Project Russh.
How do I fix CVE-2023-28113?
Upgrade russh to a fixed version for your release line: 0.36.2 or 0.37.1.
Is CVE-2023-28113 being exploited?
There is no known exploitation of CVE-2023-28113 in the wild and no public exploit code.
Other vulnerabilities in warp-tech russh
Sources
Also known as GHSA-cqvm-j2r2-hwpg.